LugerForum Discussion Forums my profile | register | faq | search
upload photo | donate | calendar

Go Back   LugerForum Discussion Forums > Luger Discussion Forums > New Collectors Forum

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Unread 08-13-2023, 01:07 PM   #1
RHRH
New User
 
Join Date: Aug 2023
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default New To This Forum - First Question!

Dear LF Group,

I just recently aquired a 1918, Erfurt, 9mm Luger and just today signed into this group. I thoroughly cleaned the gun itself and the inside and outside of the magazine. I have not fired it yet, range later this week. It appears to function ok but the toggle will not lock back. I have examined the action by removing the wooden grip panels but find nothing immediately evident. The magazine stays in the gun well and does not fall out. I have read some internet remarks on the magazine follower not engaging correctly. When I look at this I cannot see that the magzine follower has anythiing to engage with. Any ideas regarding the lack of lock back would be appreciated.

Thank you, Bob
RHRH is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:27 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2024, Jelsoft Enterprises Ltd.
Copyright 1998 - 2024, Lugerforum.com